US: 1-941-4621-069
  
Cyprus: 3-572-2052-781

Go Back   ISPsystem.com Forums > ISPmanager > Troubleshooting


Reply
 
Thread Tools
Old 05-15-2011, 07:37 AM   #1
Junior Member
 
Join Date: Jan 2011
Posts: 20
krisj is on a distinguished road
Unhappy trouble moving users between servers

Hi, hopefully you could help.
I am trying to move users between 2 ISPmanager servers. they are both running cloudlinux 5.5, with pretty much identical setup.

i am using the user import feature in ispmanager. using remote server over https.

all works well, but no e-mails get transferred.

domains are created, files get moved, db's get created, ftp users are fine too. mailbox users are created and their directories are built under /var/www/hostuser/data/email/...

but that's it.

here is whats in the usermove.log

Code:
May 15 04:44:26 [156452] INFO Restoring 'mailbox@domain.net' with status 'full'...
May 15 04:44:26 [156452] EXTINFO Execute (/bin/tar -x -o -p -m -f /tmp/pbkp_156452/hostuser/pbkp_mailbox@domain.net.tar -C /tmp/pbkp_156452/hostuser/unpacked_mailbox@domain.net/ mailbox) return=0 exited
May 15 04:44:26 [156452] INFO Converting maildir into mbox '/var/mail/virtuser_512'...
I can also see the ispmanager's temporary tarball in /tmp/<tempdir>/... being worked on during this process... and /tmp/pbkp_156452/hostuser/unpacked_mailbox@domain.net/ gets unpacked etc...

but nothing gets unpacked/moved into the final /var/www/hostuser/data/email/domain.net/mailbox

there is also a notice in the manager:

Code:
May 15 05:06:13 /*-------------Notifications from <2nd server IP>-----------------*/
May 15 05:06:13 May 15 05:20:03 zones: Failed to backup 'domain.net': code=9 Code 9 . Skip it.

May 15 05:06:13 /*------------------The end-------------------------*/

no errors or warnings in ispmgr.log

any idea how to fix this, or what might be wrong?

many thanks in advance!
krisj is offline   Reply With Quote
Old 05-15-2011, 04:03 PM   #2
ISPsystem team
 
Join Date: Oct 2009
Posts: 118
vian is on a distinguished road
Default

Please enable debug information by running
echo 9 > /usr/local/ispmgr/etc/UserMove.debug

and provide us with log UserMove.log
vian is offline   Reply With Quote
Old 05-15-2011, 05:37 PM   #3
Junior Member
 
Join Date: Jan 2011
Posts: 20
krisj is on a distinguished road
Thumbs up Here we go

Source host's UserMove.log:

http://pastebin.com/raw.php?i=sVvTfbEy

target hosts UserMove.log:

http://pastebin.com/raw.php?i=ENSVFxrb

thanks for looking into this vian!

Kris
krisj is offline   Reply With Quote
Old 05-16-2011, 02:25 PM   #4
Junior Member
 
Join Date: Jan 2011
Posts: 20
krisj is on a distinguished road
Lightbulb half solved

So, I managed to solve it myself. Turned out to be a problem with ISPmanager unable to convert the .Maildir to mbox (seems like ISPmanager defaults to mbox format on a fresh install on CentOS?) format on the target machine.

I had to add

Code:
Option Procmail 
Option MailDir
to ispmgr.conf

and change procmail's defaults to Maildir too..
/etc/procmailrc:

Code:
MAILDIR=$HOME/.maildir
DEFAULT=$MAILDIR/


so, i have it solved for now, but that doesnt change the fact that ISPmanager was unable to convert the mailboxes... perhaps you should check those routines
krisj is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 05:33 PM.