Go Back   ISPsystem.com Forums > ISPmanager > General technical discussion

Notices

Reply
 
Thread Tools
Old 05-17-2018, 12:00 AM   #1
Junior Member
 
Join Date: Aug 2012
Posts: 5
mtudor is on a distinguished road
Default Moved User to Separate Disk - Now get "an error occurred while working with files"

Hi guys,

I've been an ISPManager user for a while now, but I've just hit a bit of an odd issue. Recently I moved one of my "user" folders to a separate drive. They were at /var/www/johndoe on the primary hard disk but I added a second hard disk, moved all of the files and then mounted it at /var/www/johndoe.

So when browsing, everything looks as it did, except /var/www/johndoe is now a drive mount.

However, when I attempt to update the users www domain, even just by going in and clicking save without changing anything, I get "an error occurred while working with files". Is this something to do with ISPManager trying to use a relative link or something? I've checked permissions and they look identical to a user on the main disk.

I've also double checked and updates for other users work fine.

Any help would be most appreciated!

Thanks,

Mark.
mtudor is offline   Reply With Quote
Old 05-17-2018, 09:22 AM   #2
ISPsystem team
 
Join Date: Jul 2014
Posts: 443
ksenya is on a distinguished road
Default

Hello

Please make sure that you have mounted the John Doe user correctly.

if this doesn't help, submit a ticket to our Support center and grant access to the server with ISPmanager. Our specialists will help you resolve the issue.
ksenya is offline   Reply With Quote
Old 05-17-2018, 09:43 AM   #3
Junior Member
 
Join Date: Aug 2012
Posts: 5
mtudor is on a distinguished road
Default

Hi ksenya,

Many thanks for the reply - what should I be looking for in terms of having mounted the user correctly? All the files are accessible and the website itself works - is that enough?

Thanks,

Mark.
mtudor is offline   Reply With Quote
Old 05-18-2018, 10:14 AM   #4
ISPsystem team
 
Join Date: Jul 2014
Posts: 443
ksenya is on a distinguished road
Default

Sorry, i gave you the wrong answer in my previous post.

You need to execute mount --bind . Perhaps, the directory is mounted in a different way or the file/directory owner was changed during import.
ksenya is offline   Reply With Quote
Old 05-20-2018, 09:40 PM   #5
Junior Member
 
Join Date: Aug 2012
Posts: 5
mtudor is on a distinguished road
Default

Hi ksenya,

I'm sure it's mounted correctly and it did seem that the permissions are ok. Can you point me in the direction of any log files I could check to see if I can get a more helpful error please?

Thanks,

Mark.
mtudor is offline   Reply With Quote
Old 05-21-2018, 04:51 AM   #6
ISPsystem team
 
Join Date: Jul 2014
Posts: 443
ksenya is on a distinguished road
Default

Sorry, but I don't have any more suggestions.

Please, submit a ticket to our Support center and grant access to the server with ISPmanager. Our specialists will help
ksenya is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 01:27 AM.