US: 1-941-4621-069
  
Cyprus: 3-572-2052-781

Go Back   ISPsystem.com Forums > ISPmanager > Troubleshooting


Closed Thread
 
Thread Tools
Old 01-16-2010, 08:09 PM   #1
Junior Member
 
Join Date: Jan 2010
Posts: 8
Mono is on a distinguished road
Default Postgrey with Exim4

Hi!

We installed the Ispmanager with recommended options on Debian 5.0.3 Lenny 64 bit edition.
We go to the admin panel->Server configuration->Features and install postgrey. The postgrey installed succesfully, the bulb color is yellow and running perfectly:

# ps axf | grep postgrey
15794 pts/1 S+ 0:00 \_ grep postgrey
9074 ? Ss 0:00 /usr/sbin/postgrey --pidfile=/var/run/postgrey.pid --daemonize --inet=127.0.0.1:60000 --delay=300 --max-age=45 --greylist-text=Service unavailable. Wait a few minutes and try again.


We modified the /etc/default/postgrey file, this is the current content:

# postgrey startup options, created for Debian
# (c)2004 Adrian von Bidder <avbidder@fortytwo.ch>
# Distribute and/or modify at will.

# you may want to set
# --delay=N how long to greylist, seconds (default: 300)
# --max-age=N delete old entries after N days (default: 35)
# see also the postgrey( manpage

#POSTGREY_OPTS="--inet=127.0.0.1:60000"
POSTGREY_OPTS="--inet=127.0.0.1:60000 --delay=300 --max-age=45"

# the --greylist-text commandline argument can not be easily passed through
# POSTGREY_OPTS when it contains spaces. So, insert your text here:
#POSTGREY_TEXT="Your customized rejection message here"
POSTGREY_TEXT="Service unavailable. Wait a few minutes and try again."



We put in the /usr/local/ispmgr/etc/ispmgr.conf the following line:
Option ForcePostgrey

After this steps, we restarted ispmanager with "killall ispmgr" shell command.

But the postgrey don't working. When coming a new email first, the recipient become it in a moment.
We could't find any postgrey message the following log files:
/var/log/messages
/var/log/exim4/mainlog
/var/log/mail.log

Why don't work postgrey? What is the problem?

Thanks!
Mono is offline  
Old 01-17-2010, 03:15 AM   #2
ISPsystem team
 
slava's Avatar
 
Join Date: May 2008
Location: ISPsystem
Posts: 588
slava is on a distinguished road
Default

Can you check exim configuration for POSTGREY_SOCKET option?
slava is offline  
Old 01-19-2010, 07:18 PM   #3
Junior Member
 
Join Date: Jan 2010
Posts: 8
Mono is on a distinguished road
Default

Dear Slava!

It was a trivial problem.
When we installed the postgrey "feature" in the /etc/default/postgrey configuration file the postgrey listeting on the 60000 TCP port.
And the Exim4 config file (/etc/exim4/exim4.conf.template) wanted communicate with unix socket.
We changed in the postgrey config file from inet= to unix= and working fine.

Thanks!
__________________
Sorry, but I can't speak very good English.
Mono is offline  
Closed Thread

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 01:39 AM.