US: 1-941-4621-069
  
Cyprus: 3-572-2052-781

Go Back   ISPsystem.com Forums > ISPmanager > Troubleshooting


Reply
 
Thread Tools
Old 09-17-2012, 04:36 PM   #1
Junior Member
 
Join Date: Sep 2012
Posts: 4
syntaxsniffer is on a distinguished road
Unhappy PHP as CGI - PHP.INI

I am running CENT OS 6.3 x64 with the default install of the newest ISP Manager Pro.

PHP.INI is not working. I did a "locate php.ini" on the system and I see there is one in /etc/php.ini and a php.ini file in each domain folder (ISP Manager Pro does this on it's own when you create a site but there are only two lines in it).

I set the master settings for the server in there. They SHOULD be processed first then the one in the domain folders. But /etc/php.ini is being ignored completely. Leaving php running the default for all options other than the two php manager adds. I saw one other thread on here where someone else was having the same problem but no one provided an answer.

running phpinfo() shows the configuration file location is /etc.
then under that it shows loaded as being the one in the domain directory.

This normally wouldn't be a problem but the latest versions of php want a date.timezone entered. I put the date.timezone parameter in the /etc/php.ini but the domains all ignore it and report that php needs it.

Thoughts?
syntaxsniffer is offline   Reply With Quote
Old 09-17-2012, 07:54 PM   #2
ISPsystem team
 
slava's Avatar
 
Join Date: May 2008
Location: ISPsystem
Posts: 588
slava is on a distinguished road
Default

Try add date.timezone to user's php.ini in user home directory /var/www/user/php-bin/php.ini
slava is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 08:12 PM.