Go Back   ISPsystem.com Forums > ISPmanager > Feedback & Feature Requests

Notices

Reply
 
Thread Tools
Old 08-26-2004, 11:17 AM   #1
Junior Member
 
Join Date: Jul 2004
Posts: 11
emkay
Default Apache overrides

Hello,

When ISPManager creates a new account, it enters something like the following into httpd.conf

---
<Directory /home/domain.com>
Options -Indexes +ExecCGI +Includes
</Directory>
---

If you try to allow this user to override any of the apache settings by adding:

'AllowOverride All'

even after a reboot, the changes will not stick.
I've found that you have to specify the htdocs folder or include all folders to get this working. eg.

---
<Directory /home/domain.com/htdocs>
Options -Indexes +ExecCGI +Includes
AllowOverride All
</Directory>
---
or
---
<Directory /home/feelingmusical.com/htdocs/*>
Options -Indexes +ExecCGI +Includes
AllowOverride All
</Directory>
---

Is there any reason why ISPManager does not do it this way?

Thanks
mk
emkay is offline   Reply With Quote
Old 08-27-2004, 07:10 AM   #2
ISPsystem team
 
Join Date: Jun 2004
Posts: 3
alm has disabled reputation
Default

There are you have

<Directory /home/*>
Options +Includes
AllowOverride AuthConfig Limit Indexes Options
</Directory>

Change AllowOverride here.
alm is offline   Reply With Quote
Old 08-27-2004, 10:27 AM   #3
Junior Member
 
Join Date: Jul 2004
Posts: 11
emkay
Default

But, I don't want to change it globally. Just for each site.
emkay is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 11:59 AM.