US: 1-941-4621-069
  
Cyprus: 3-572-2052-781

Go Back   ISPsystem.com Forums > ISPmanager > Troubleshooting

Notices

Reply
 
Thread Tools
Old 06-29-2011, 06:14 AM   #1
Junior Member
 
Join Date: Jul 2009
Posts: 4
hugohiram is on a distinguished road
Default problems setting domain

Hello,

I have ISPmanager-Pro 4.3.56.4, I have succesfully created multiple domains, but when I try to modify the settings for any of them, nothing happens. This is what happens;

First, I tried to modify the file the DirectoryIndex parameter from ISPmanager, restart apache, nothing happens...

Then, I tried to modify the document root to a subfolder in the root editing the /etc/apache2/apache2.conf file, restart apache, same result, nothing... I also tried the the "config" button on the domains list with no luck.

This is the virtual host, on my /etc/apache2/apache2.conf file, with the original names changed:

DirectoryIndex changed:

Quote:
<VirtualHost SERVER_IP:80>
ServerName sub.domain.com
DocumentRoot /var/www/USER/data/www/sub.domain.com
SuexecUserGroup USER USER
CustomLog /var/www/httpd-logs/sub.domain.com.access.log combined
ErrorLog /var/www/httpd-logs/sub.domain.com.error.log
ServerAlias www.sub.domain.com
ServerAdmin MY_EMAIL
ScriptAlias /cgi-bin/ /var/www/USER/data/www/sub.domain.com/cgi-bin/
php_admin_value open_basedir "/var/www/USER/data:."
php_admin_value sendmail_path "/usr/sbin/sendmail -t -i -f MY_EMAIL"
php_admin_value upload_tmp_dir "/var/www/USER/data/mod-tmp"
php_admin_value session.save_path "/var/www/USER/data/mod-tmp"
php_admin_value safe_mode "on"
AddType application/x-httpd-php .php .php3 .php4 .php5 .phtml
AddType application/x-httpd-php-source .phps
AddDefaultCharset ISO-8859-1
DirectoryIndex info.php
</VirtualHost>
DocumentRoot changed:

Quote:
<VirtualHost SERVER_IP:80>
ServerName sub.domain.com
DocumentRoot /var/www/USER/data/www/sub.domain.com/public
SuexecUserGroup USER USER
CustomLog /var/www/httpd-logs/sub.domain.com.access.log combined
ErrorLog /var/www/httpd-logs/sub.domain.com.error.log
ServerAlias www.sub.domain.com
ServerAdmin MY_EMAIL
ScriptAlias /cgi-bin/ /var/www/USER/data/www/sub.domain.com/cgi-bin/
php_admin_value open_basedir "/var/www/USER/data:."
php_admin_value sendmail_path "/usr/sbin/sendmail -t -i -f MY_EMAIL"
php_admin_value upload_tmp_dir "/var/www/USER/data/mod-tmp"
php_admin_value session.save_path "/var/www/USER/data/mod-tmp"
php_admin_value safe_mode "on"
AddType application/x-httpd-php .php .php3 .php4 .php5 .phtml
AddType application/x-httpd-php-source .phps
AddDefaultCharset ISO-8859-1
</VirtualHost>
I need help, I don't know what is happening.

Regards,
Hugo.

Last edited by hugohiram; 06-29-2011 at 07:42 AM. Reason: needed to add one step that I forgot
hugohiram is offline   Reply With Quote
Old 06-29-2011, 11:02 AM   #2
ISPsystem team
 
Join Date: Jan 2009
Posts: 111
GakcaT is on a distinguished road
Default

Could you provide the part of ispmgr.log that is created when you perform the actions?
GakcaT is offline   Reply With Quote
Old 06-29-2011, 01:56 PM   #3
Junior Member
 
Join Date: Jul 2009
Posts: 4
hugohiram is on a distinguished road
Default

Yes, I will send you a private message with the data.
hugohiram is offline   Reply With Quote
Old 06-30-2011, 09:38 AM   #4
ISPsystem team
 
Join Date: Jan 2009
Posts: 111
GakcaT is on a distinguished road
Default

Got the message, sent you a reply.
GakcaT is offline   Reply With Quote
Old 07-05-2011, 09:38 AM   #5
Junior Member
 
Join Date: Jul 2009
Posts: 4
hugohiram is on a distinguished road
Default

Hi,

Did you get my last message with the log file?

Regards.
hugohiram is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 05:38 AM.