Go Back   ISPsystem.com Forums > ISPmanager > General technical discussion

Notices

Reply
 
Thread Tools
Old 08-30-2018, 02:27 PM   #1
Junior Member
 
Join Date: Aug 2018
Posts: 2
laurx2000 is on a distinguished road
Default FastCGI (Nginx + PHP-FPM error 404

Hi!
On ispsystem-5.165 lite, CentOS 7.5.1804.4.el7, I installed prestashop 1.7.4.2 and activated:
- PHP 7.2 Apache module, PHP 7.2 CGI, PHP 7.2 PHP-FPM
- webserver with Apache MPM-ITK 2.4.6-80.el7.centos.1, PHP module 5.4.16-45.el7, PHP-FPM 5.4.16-45.el7, logrotate 3.8.6-15.el7 , nginx 1.14.0-1.el7_4.ngx
- www-domains with FastCGI (Nginx + PHP-FPM)

It works just the homepage, another page 404 Not Found
nginx / 1.14.0.
In principle, prestashop should work with FastCGI (Nginx + PHP-FPM), but it does not work for me.

Thanks for any help!
laurx2000 is offline   Reply With Quote
Old 09-05-2018, 05:48 PM   #2
ISPsystem team
 
Join Date: Jul 2014
Posts: 441
ksenya is on a distinguished road
Default

It seems that prestashop was installed when Apache was running and now its internal links work through .htacces which is compatible only with Apache.

Check it in the Apache mode. If everything is up and running, you use the .htaccess file and it will work only in this mode.

And change rewrites manually:
http://doc.prestashop.com/display/PS...nxfriendlyURLs
ksenya is offline   Reply With Quote
Reply

Tags
nginx + php-fpm, prestashop

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 03:53 PM.