US: 1-941-4621-069
  
Cyprus: 3-572-2052-781

Go Back   ISPsystem.com Forums > ISPmanager > Installation / System Requirements


Reply
 
Thread Tools
Old 09-12-2009, 12:04 AM   #1
Junior Member
 
Join Date: Sep 2009
Posts: 10
rennsix is on a distinguished road
Default Getting ISPManager to recognizing new php5.3.0

First off, I'd like to say that I really like the choice of control panels that VPS.net has offered their customers. It's so nice having a friendly GUI for those shared hosting converts. Thank You!

I have a control panel and php question.

I've recently upgraded my php version from 5.1.6 to 5.3.0 using a How-To from vps.net forum. I believe it was successful as seen below. I also ran:

php -m

like they said and it spit out

[userxxx@myvpsname ~]# php -v
PHP 5.3.0 (cli) (built: Sep 11 2009 10:54:0
Copyright (c) 1997-2009 The PHP Group
Zend Engine v2.3.0, Copyright (c) 1998-2009 Zend Technologies

I then shutdown my vps and restarted it. I logged into ISPManagerPro and went to Tools -Server Configuration - Featured - PHP Scripting Language it still says php-5.1.6-23.2.el5_3.

The question is how do I associate the new version?

I have php5.3.0 in my main server folder named 'root'

I have a centos 5.2 running lamp.

Do I maybe have to uninstall something?

Any suggestions or links would be helpful. I know for a fact there are a few other people on the vps.net forum that are still wondering the same thing as I am.

Cheer,
Colin
rennsix is offline   Reply With Quote
Old 09-12-2009, 05:19 PM   #2
ISPsystem team
 
Join Date: Jan 2009
Posts: 111
GakcaT is on a distinguished road
Default

What version of PHP do you see in the module "Features"?

Last edited by GakcaT; 09-12-2009 at 05:41 PM.
GakcaT is offline   Reply With Quote
Old 09-12-2009, 09:02 PM   #3
Junior Member
 
Join Date: Sep 2009
Posts: 10
rennsix is on a distinguished road
Default

php-5.1.6-23.2.el5_3
rennsix is offline   Reply With Quote
Old 09-13-2009, 03:16 AM   #4
ISPsystem team
 
Join Date: Jan 2009
Posts: 111
GakcaT is on a distinguished road
Default

You should refresh the ISPmanager packages database. Execute:
/usr/local/ispmgr/sbin/pkgctl cache
killall ispmgr
GakcaT is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 12:02 AM.