US: 1-941-4621-069
  
Cyprus: 3-572-2052-781

Go Back   ISPsystem.com Forums > ISPmanager > General technical discussion


Reply
 
Thread Tools
Old 02-18-2016, 10:36 PM   #1
Member
 
Join Date: Jan 2013
Posts: 38
dragon is on a distinguished road
Default ubuntu lts upgrade problem (ipv6 related)

After upgrade I have some problems with upgrade
First was problem with ipv6 connections with download.ispsystem.com

W: Failed to fetch http://download.ispsystem.com/repo/u...amd64/Packages 404 Not Found [IP: 2a01:230:2::52d 80]

W: Failed to fetch http://download.ispsystem.com/repo/u...-i386/Packages 404 Not Found [IP: 2a01:230:2::52d 80]

E: Some index files failed to download. They have been ignored, or old ones used instead.

Now I have installed 5.50 version but also some problems with dependencies

After switching to ipv4, can't fetch old dependencies

W: Failed to fetch http://download.ispsystem.com/repo/u...amd64/Packages 404 Not Found

W: Failed to fetch http://download.ispsystem.com/repo/u...-i386/Packages 404 Not Found

And with apt-get uprade got this

Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
ispmanager-pkg-awstats : Depends: ispmanager-lite-common (= 5.48.0-trusty1) but 5.50.0-trusty2 is installed or
ispmanager-node-common (= 5.48.0-trusty1) but it is not installable
ispmanager-pkg-clamav-exim : Depends: ispmanager-lite-common (= 5.48.0-trusty1) but 5.50.0-trusty2 is installed or
ispmanager-node-common (= 5.48.0-trusty1) but it is not installable
ispmanager-pkg-dovecot : Depends: ispmanager-lite-common (= 5.48.0-trusty1) but 5.50.0-trusty2 is installed or
ispmanager-node-common (= 5.48.0-trusty1) but it is not installable
ispmanager-pkg-exim : Depends: ispmanager-lite-common (= 5.48.0-trusty1) but 5.50.0-trusty2 is installed or
ispmanager-node-common (= 5.48.0-trusty1) but it is not installable
ispmanager-pkg-greylisting-exim : Depends: ispmanager-lite-common (= 5.48.0-trusty1) but 5.50.0-trusty2 is installed or
ispmanager-node-common (= 5.48.0-trusty1) but it is not installable
ispmanager-pkg-logrotate : PreDepends: ispmanager-lite-common (= 5.48.0-trusty1) but 5.50.0-trusty2 is installed or
ispmanager-node-common (= 5.48.0-trusty1) but it is not installable
ispmanager-pkg-myadmin : Depends: ispmanager-lite-common (= 5.48.0-trusty1) but 5.50.0-trusty2 is installed or
ispmanager-node-common (= 5.48.0-trusty1) but it is not installable
ispmanager-pkg-mysql : Depends: ispmanager-lite-common (= 5.48.0-trusty1) but 5.50.0-trusty2 is installed or
ispmanager-node-common (= 5.48.0-trusty1) but it is not installable
ispmanager-pkg-pureftpd : Depends: ispmanager-lite-common (= 5.48.0-trusty1) but 5.50.0-trusty2 is installed or
ispmanager-node-common (= 5.48.0-trusty1) but it is not installable
ispmanager-pkg-quota : Depends: ispmanager-lite-common (= 5.48.0-trusty1) but 5.50.0-trusty2 is installed or
ispmanager-node-common (= 5.48.0-trusty1) but it is not installable
ispmanager-pkg-roundcube : Depends: ispmanager-lite-common (= 5.48.0-trusty1) but 5.50.0-trusty2 is installed or
ispmanager-node-common (= 5.48.0-trusty1) but it is not installable
ispmanager-pkg-sieve : Depends: ispmanager-lite-common (= 5.48.0-trusty1) but 5.50.0-trusty2 is installed or
ispmanager-node-common (= 5.48.0-trusty1) but it is not installable
ispmanager-pkg-spamassassin-exim : Depends: ispmanager-lite-common (= 5.48.0-trusty1) but 5.50.0-trusty2 is installed or
ispmanager-node-common (= 5.48.0-trusty1) but it is not installable
E: Unmet dependencies. Try using -f.

Any suggestion to fix this? I've got unfortunatelly automatic updates (isp and system)
because apt-get -f install now can create disaster

root@web:~# apt-get -f install
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following packages were automatically installed and are no longer required:
augeas-lenses augeas-tools awstats clamav-base clamav-daemon
clamav-freshclam dbconfig-common dovecot-core dovecot-imapd dovecot-pop3d
dovecot-sieve libaugeas0 libberkeleydb-perl libclamav6 libdigest-hmac-perl
libencode-locale-perl libfile-copy-recursive-perl libfile-listing-perl
libhtml-parser-perl libhtml-tagset-perl libhtml-tree-perl
libhttp-cookies-perl libhttp-date-perl libhttp-message-perl
libhttp-negotiate-perl libio-html-perl libio-multiplex-perl
libio-socket-inet6-perl libio-socket-ssl-perl libjs-codemirror libjs-jquery
libjs-jquery-cookie libjs-jquery-event-drag libjs-jquery-metadata
libjs-jquery-mousewheel libjs-jquery-tablesorter libjs-jquery-ui
libjs-underscore liblwp-mediatypes-perl liblwp-protocol-https-perl
libmemcached10 libmemcachedutil2 libnet-cidr-perl libnet-dns-perl
libnet-http-perl libnet-ip-perl libnet-server-perl libnet-ssleay-perl
libnetaddr-ip-perl libsocket6-perl libsys-hostname-long-perl
libtimedate-perl liburi-perl libwww-perl libwww-robotrules-perl
linux-headers-3.13.0-66 linux-headers-3.13.0-66-generic
linux-headers-3.13.0-76 linux-headers-3.13.0-76-generic
linux-image-3.13.0-66-generic linux-image-3.13.0-76-generic
linux-image-extra-3.13.0-66-generic linux-image-extra-3.13.0-76-generic
openbsd-inetd php-auth php-gettext php-mail-mime php-net-smtp php-net-socket
php5 php5-intl php5-mcrypt php5-mysql phpmyadmin postgrey pure-ftpd
pure-ftpd-common quota roundcube roundcube-core roundcube-mysql spamassassin
tinymce update-inetd
Use 'apt-get autoremove' to remove them.
The following packages will be REMOVED:
ispmanager-pkg-awstats ispmanager-pkg-clamav-exim ispmanager-pkg-dovecot
ispmanager-pkg-exim ispmanager-pkg-greylisting-exim ispmanager-pkg-logrotate
ispmanager-pkg-myadmin ispmanager-pkg-mysql ispmanager-pkg-pureftpd
ispmanager-pkg-quota ispmanager-pkg-roundcube ispmanager-pkg-sieve
ispmanager-pkg-spamassassin-exim
0 upgraded, 0 newly installed, 13 to remove and 7 not upgraded.
3 not fully installed or removed.
After this operation, 721 kB disk space will be freed.

:/
dragon is offline   Reply With Quote
Old 02-19-2016, 07:57 AM   #2
ISPsystem team
 
Join Date: Jun 2013
Posts: 233
fly is on a distinguished road
Default

Hello,

Non existing repository is added. Please execute a command /usr/local/mgr5/sbin/licctl fetch ispmgr

and check repository after that. It should be 5.50 or 5.51. If a command doesn't help, please change repository by hand or write us a support ticket.
fly is offline   Reply With Quote
Old 02-19-2016, 07:31 PM   #3
Member
 
Join Date: Jan 2013
Posts: 38
dragon is on a distinguished road
Default

Thank You for advice, I've done what You suggest, now output looks much better

root@web:~# apt-get -f install
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following packages were automatically installed and are no longer required:
augeas-lenses augeas-tools libaugeas0 libmemcached10 libmemcachedutil2
linux-headers-3.13.0-66 linux-headers-3.13.0-66-generic
linux-headers-3.13.0-76 linux-headers-3.13.0-76-generic
linux-image-3.13.0-66-generic linux-image-3.13.0-76-generic
linux-image-extra-3.13.0-66-generic linux-image-extra-3.13.0-76-generic
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
ispmanager-pkg-awstats ispmanager-pkg-clamav-exim ispmanager-pkg-dovecot
ispmanager-pkg-exim ispmanager-pkg-greylisting-exim ispmanager-pkg-logrotate
ispmanager-pkg-myadmin ispmanager-pkg-mysql ispmanager-pkg-pureftpd
ispmanager-pkg-quota ispmanager-pkg-roundcube ispmanager-pkg-sieve
ispmanager-pkg-spamassassin-exim
The following packages will be upgraded:
ispmanager-pkg-awstats ispmanager-pkg-clamav-exim ispmanager-pkg-dovecot
ispmanager-pkg-exim ispmanager-pkg-greylisting-exim ispmanager-pkg-logrotate
ispmanager-pkg-myadmin ispmanager-pkg-mysql ispmanager-pkg-pureftpd
ispmanager-pkg-quota ispmanager-pkg-roundcube ispmanager-pkg-sieve
ispmanager-pkg-spamassassin-exim
13 upgraded, 0 newly installed, 0 to remove and 12 not upgraded.
3 not fully installed or removed.
Need to get 45.3 kB of archives.
After this operation, 1,024 B of additional disk space will be used.
Do you want to continue? [Y/n]

How do You think, it should be safe now? (I think)

If You think the same, I'll upgrade both servers tommorow
dragon is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 08:31 PM.