US: 1-941-4621-069
  
Cyprus: 3-572-2052-781

Go Back   ISPsystem.com Forums > ISPmanager > Troubleshooting

Notices

Reply
 
Thread Tools
Old 10-29-2011, 12:27 PM   #1
Junior Member
 
Join Date: Oct 2011
Posts: 25
paketschubser is on a distinguished road
Default problem with branding

Hello,

I've changed the branding of the webinterface (images and colors). As long as I'm logged in as a user everything looks fine, the colors and images were displayed according my settings. Also when I log out the login screen is still customized but as soon as I press the reload button in the browser (after logout) the branding disappears and everything got it's original settings. The second place where branding does not work is the login screen when called directly by https://<servername>/manager/.

After some testing (first I thought it might be a cache issue of my browser) I've found the following reason for this behavior:

When I log out the source code of the website contains the following code for the stylesheet:
Code:
<link href="/manimg/sirius/local/main.css?1313091193" rel="stylesheet" type="text/css">
After pressing the reload button this changes to:
Code:
<link href="/manimg/sirius/main.css?1313091193" rel="stylesheet" type="text/css">
The problem occurs in ISPmanager-Pro 4.3.57.9, I've got another installation with ISPmanager-Lite 4.3.57.9 where everything works fine. Any ideas how to fix this?

Last edited by paketschubser; 10-31-2011 at 02:13 PM.
paketschubser is offline   Reply With Quote
Old 10-31-2011, 09:38 AM   #2
ISPsystem team
 
Join Date: Jun 2010
Posts: 46
Lorelei is on a distinguished road
Default

I've registered bug #6568 for developers, thanks a lot for your report
Lorelei is offline   Reply With Quote
Old 11-17-2011, 09:12 AM   #3
ISPsystem team
 
Join Date: Jan 2011
Posts: 7
galaxymike is on a distinguished road
Default

There is no error.
You need to set the option DefaultRootBrand (http://en.ispdoc.com/index.php/Brand_settings), otherwise the panel did not understand whose brand to take the base for the login page.
galaxymike is offline   Reply With Quote
Old 11-18-2011, 01:13 AM   #4
Junior Member
 
Join Date: Oct 2011
Posts: 25
paketschubser is on a distinguished road
Default

Quote:
Originally Posted by galaxymike View Post
There is no error.
You need to set the option DefaultRootBrand (http://en.ispdoc.com/index.php/Brand_settings), otherwise the panel did not understand whose brand to take the base for the login page.
Oh, ok - thank you, I didn't know this option. Maybe it would be a good idea to list this also at the documentation of the configuration file.
paketschubser is offline   Reply With Quote
Old 12-02-2011, 04:07 AM   #5
ISPsystem team
 
Join Date: Oct 2009
Posts: 118
vian is on a distinguished road
Default

We'll fix this issue. Thank you.
vian is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 11:52 AM.