US: 1-941-4621-069
  
Cyprus: 3-572-2052-781

Go Back   ISPsystem.com Forums > ISPmanager > Troubleshooting


Reply
 
Thread Tools
Old 06-11-2012, 03:27 PM   #1
Member
 
Join Date: Oct 2009
Posts: 71
Helmi is on a distinguished road
Default Problem installing applications

Hi,

i had to remove squirrelmail and phpmyadmin packages during a php update to php53 due to conflicts. after solving everything i wanted to reinstall them via the applications menu in ispmanager. there are compatible versions in the repistories.

I've cleared the pkg cache in isp manager using

Code:
 /usr/local/ispmgr/sbin/pkgctl cache
i also did a yum clean all (I'm on Cloud Linux).

Both (MysQL Manager and Webmailer) showd a yellow lamp in isp manager. After hitting deinstall there the yellow lamp turned grey but i still can't install the new packages. if i click install the popup appears and the compatible packages show there but if i click install the page reloads but now installation-icon (the little spinning CD) appears and nothing happens.

Any idea how i can fix that?

Thanks for helping.

Frank

One more thing: I'm able to install any other modules - just the two that were removed outside of ips manager don't seem to work. there seems to be any setting in isp manager that thinks they're still tfhere or something like that.

Last edited by Helmi; 06-11-2012 at 03:30 PM.
Helmi is offline   Reply With Quote
Old 06-11-2012, 03:41 PM   #2
Member
 
Join Date: Oct 2009
Posts: 71
Helmi is on a distinguished road
Default

hmm i found that in var/run/ispmgr a file called pkgctl.myadmin (for example) says

"ERR php requered to install myadmin"

Which is strange because i can install and remove the package with yum without any error. Does isp manager use yum or any other method?

I've mapped my php53 packages to php for compatiblity issues - maybe that's a problem for isp manager? It's not for yum...
Helmi is offline   Reply With Quote
Old 06-12-2012, 08:28 AM   #3
Member
 
Join Date: Oct 2009
Posts: 71
Helmi is on a distinguished road
Default

hmm really no one able to help here?
Helmi is offline   Reply With Quote
Old 06-12-2012, 05:03 PM   #4
ISPsystem team
 
slava's Avatar
 
Join Date: May 2008
Location: ISPsystem
Posts: 588
slava is on a distinguished road
Default

PHP should be enabled and installed in the Applications menu. If it's not - you can try change /usr/local/ispmgr/etc/pkg-isp.conf file for "enable" this option.
slava is offline   Reply With Quote
Old 06-12-2012, 08:28 PM   #5
Member
 
Join Date: Oct 2009
Posts: 71
Helmi is on a distinguished road
Default

I'm using php53u from ISU community repo which is linked to the old php version to support php-common and stuff (centOS default doesn't support this).

ISP manager only offers some other php packages there. Even though php is installed and works fine it doesn't show up in isp manager.

What is the preffered way for isp manager to use the correct package? I have worries that isp manager changes my installed php when i choos one of the other packages.

Frank
Helmi is offline   Reply With Quote
Old 06-13-2012, 07:24 AM   #6
ISPsystem team
 
slava's Avatar
 
Join Date: May 2008
Location: ISPsystem
Posts: 588
slava is on a distinguished road
Default

Set PhpMyAdmin manually via yum can cause problems with dependencies, or do the "dirty hack" in the pkg-isp.conf
slava is offline   Reply With Quote
Old 06-13-2012, 07:26 AM   #7
Member
 
Join Date: Oct 2009
Posts: 71
Helmi is on a distinguished road
Default

ok i did that and it seems to work. What are the dependencie problems you are talking about? I'd like to check them by hand to be sure everything is fine.
Helmi is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 02:12 AM.