Go Back   ISPsystem.com Forums > ISPmanager > Troubleshooting

Notices

Reply
 
Thread Tools
Old 05-16-2018, 03:45 PM   #1
Junior Member
 
Join Date: Mar 2018
Location: HR, Zagreb
Posts: 10
miro is on a distinguished road
Default Can't recieve any emails

I guess my ISP system is using active Exim as a default MTA. (thats what I see from gui)

I'm on dynamic ip, and I'm sending emails through my ISP smarthost, I specified settings in config file, and I can send emails from my exim server without problems. They are delivered.

But I have problem with receiving emails, when I try to send email from external address to my ISP domain, I get auto respond email from my exim mail server and I can't resolve whats wrong!

From: Mail Delivery System <Mailer-Daemon@isp1.mydomain.com>

This message was created automatically by mail delivery software.

A message that you sent could not be delivered to one or more of its
recipients. This is a permanent error. The following address(es) failed:

admin@mydomain.com

Action: failed
Final-Recipient: rfc822;admin@mydomain.com
Status: 5.0.0

Code:
Content-Type: multipart/report; report-type=delivery-status; boundary=1526475800-eximdsn-1804289383
MIME-Version: 1.0
Subject: Mail delivery failed: returning message to sender
Message-Id: <E1fIw5R-00081y-0D@isp1.mydomain.com>
Date: Wed, 16 May 2018 15:03:21 +0200
X-KLMS-Rule-ID: 1
X-KLMS-Message-Action: clean
X-KLMS-AntiSpam-Lua-Profiles: 123108 [Apr 01 2018]
X-KLMS-AntiSpam-Version: 5.7.102.0
X-KLMS-AntiSpam-Rate: 0
X-KLMS-AntiSpam-Status: formal
X-KLMS-AntiSpam-Method: none
X-KLMS-AntiSpam-Info: LuaCore: 118 118 1d3ca9104b311f1f878f20ec1484836dccfbc23a, {Formal}, {msgid_created_by_recepient}, {Tracking_autoreply, sub}, DmarcAF: none
X-KLMS-AntiSpam-Interceptor-Info: scan successful
X-KLMS-AntiPhishing: Clean, 2018/03/30 14:19:30
X-KLMS-AntiVirus: Kaspersky Security 8.0 for Linux Mail Server, version 8.0.1.705, bases: 2018/03/31 18:25:00 #11406819; khse: 2014-01-23 rollback
X-KLMS-AntiVirus-Status: Clean, skipped


It's not delivered in roundcube inbox. I don't know why.

I know that mailbox exists because I can send from it.

Last edited by miro; 05-16-2018 at 03:57 PM.
miro is offline   Reply With Quote
Old 05-17-2018, 01:57 PM   #2
ISPsystem team
 
Join Date: Jul 2014
Posts: 443
ksenya is on a distinguished road
Default

Hello

You need to add the following into the configuration file

domainlist dummy_domains = lsearch;/etc/exim/domains

It already contains domainlist dummy_domains so you need to add the value after =
ksenya is offline   Reply With Quote
Old 05-17-2018, 03:55 PM   #3
Junior Member
 
Join Date: Mar 2018
Location: HR, Zagreb
Posts: 10
miro is on a distinguished road
Default

ksenya thanks for support,

I edited line like you told in exim config but error is still the same.

I reviewed logs of dovecot and exim and I can actually see that my mail is delivered to mail server, in dovecot logs it says:

--------------------------------
action pass , reason-triplet-found
-------------------------------
and then .... CV=no, TEMPORARILY REJECTED RCPT; graylisted host

Too many "received" headers , suspected mail loop

------------------------------

I used windows telnet to check listening, and dovecot is listening port 143, exim is listening at 25.
miro is offline   Reply With Quote
Old 05-18-2018, 10:24 AM   #4
ISPsystem team
 
Join Date: Jul 2014
Posts: 443
ksenya is on a distinguished road
Default

It seems that your email is in infinite loop because in our standard Exim configuration it first checks its MX-record and sends the email to any place. And the client uses external static IP as the MX record, so he always sends the email only to himself. dummy_domains informs Exim that emails should not be sent that way to the specified domain names.
ksenya is offline   Reply With Quote
Old 05-18-2018, 08:42 PM   #5
Junior Member
 
Join Date: Mar 2018
Location: HR, Zagreb
Posts: 10
miro is on a distinguished road
Default

This is how external dns zone look like , it's static set on namecheap.com:

I have set two A records to my local ip address

A isp1 192.168.1.250
A mail 192.168.1.250

I also set 2 CNAME records

isp1 mylocal.dyndnsname.com
mail mylocal.dyndnsname.com

and ofcourse MX record

@ isp1.mydomainname.com

isp1 is hostname, fqdn hostname is isp1.mydomainname.com

I didn't touched internal dns zone inside ISPmanager.

Hope there is way for exim to make it work, it may also be good idea to check if clear installation of exim under centos7 supports email delivery this way.
miro is offline   Reply With Quote
Old 05-21-2018, 06:52 AM   #6
ISPsystem team
 
Join Date: Jul 2014
Posts: 443
ksenya is on a distinguished road
Default

The cause of the issue does not relate to MX. The thing is that Exim doesn't know about local domain. The string that I gave you above should help.

please note - this topic does not relate to ISPmanager settings, so we cannot help you with your mail server setup.
ksenya is offline   Reply With Quote
Old 05-21-2018, 09:57 AM   #7
Junior Member
 
Join Date: Mar 2018
Location: HR, Zagreb
Posts: 10
miro is on a distinguished road
Default

I see , so obvious problem is in exim configuration file syntax?
miro is offline   Reply With Quote
Old 05-22-2018, 02:50 PM   #8
Junior Member
 
Join Date: Mar 2018
Location: HR, Zagreb
Posts: 10
miro is on a distinguished road
Default

it works with the code you told me to insert, but I had to delete all domain mailboxes - disable mail server feature, and reinstall it.
miro is offline   Reply With Quote
Old 05-24-2018, 08:18 AM   #9
ISPsystem team
 
Join Date: Jul 2014
Posts: 443
ksenya is on a distinguished road
Default

Yes, the problem is the Exim configuration.
ksenya is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 01:49 PM.