View Single Post
Old 01-16-2010, 08:09 PM   #1
Junior Member
Join Date: Jan 2010
Posts: 8
Mono is on a distinguished road
Default Postgrey with Exim4


We installed the Ispmanager with recommended options on Debian 5.0.3 Lenny 64 bit edition.
We go to the admin panel->Server configuration->Features and install postgrey. The postgrey installed succesfully, the bulb color is yellow and running perfectly:

# ps axf | grep postgrey
15794 pts/1 S+ 0:00 \_ grep postgrey
9074 ? Ss 0:00 /usr/sbin/postgrey --pidfile=/var/run/ --daemonize --inet= --delay=300 --max-age=45 --greylist-text=Service unavailable. Wait a few minutes and try again.

We modified the /etc/default/postgrey file, this is the current content:

# postgrey startup options, created for Debian
# (c)2004 Adrian von Bidder <>
# Distribute and/or modify at will.

# you may want to set
# --delay=N how long to greylist, seconds (default: 300)
# --max-age=N delete old entries after N days (default: 35)
# see also the postgrey( manpage

POSTGREY_OPTS="--inet= --delay=300 --max-age=45"

# the --greylist-text commandline argument can not be easily passed through
# POSTGREY_OPTS when it contains spaces. So, insert your text here:
#POSTGREY_TEXT="Your customized rejection message here"
POSTGREY_TEXT="Service unavailable. Wait a few minutes and try again."

We put in the /usr/local/ispmgr/etc/ispmgr.conf the following line:
Option ForcePostgrey

After this steps, we restarted ispmanager with "killall ispmgr" shell command.

But the postgrey don't working. When coming a new email first, the recipient become it in a moment.
We could't find any postgrey message the following log files:

Why don't work postgrey? What is the problem?

Mono is offline