ISPsystem.com Forums

ISPsystem.com Forums (http://forum.ispsystem.com//index.php)
-   Troubleshooting (http://forum.ispsystem.com//forumdisplay.php?f=11)
-   -   open_basedir restriction problem (http://forum.ispsystem.com//showthread.php?t=968)

Nemesis 03-29-2010 07:06 PM

open_basedir restriction problem
 
Ok, I'm having an open_basedir restriction issue. My configuration in apache looks like this:

php_admin_value open_basedir "/var/www/example/data:."
php_admin_value sendmail_path "/usr/sbin/sendmail -t -i -f webmaster@example.com"
php_admin_value upload_tmp_dir "/var/www/example/data/mod-tmp"
php_admin_value session.save_path "/var/www/example/data/mod-tmp"

However, when I try using wordpress to update a file, it attempts to download the file to /tmp and causes the following error messages.

Warning: file_exists() [function.file-exists]: open_basedir restriction in effect. File(/tmp//1269397030) is not within the allowed path(s): (/var/www/example/data:.) in /var/www/example/data/www/example.com/wp-includes/functions.php on line 1924

Warning: touch() [function.touch]: open_basedir restriction in effect. File(/tmp/1269397030) is not within the allowed path(s): (/var/www/example/data:.) in /var/www/example/data/www/example.com/wp-admin/includes/file.php on line 174

Warning: fileowner() [function.fileowner]: open_basedir restriction in effect. File(/tmp/1269397030) is not within the allowed path(s): (/var/www/example/data:.) in /var/www/example/data/www/example.com/wp-admin/includes/file.php on line 628

Warning: unlink() [function.unlink]: open_basedir restriction in effect. File(/tmp/1269397030) is not within the allowed path(s): (/var/www/example/data:.) in /var/www/example/data/www/example.com/wp-admin/includes/file.php on line 630

Is there any advice or any articles you can point me too which would solve this issue? I have my ISPManager Pro set up to use php as an apache module, and I'm running Ubuntu 8.04 LTS. Any help with this would be truly appreciated.

Thanks.

Nemesis 03-29-2010 11:13 PM

Scratch that, it seems it was an error with the php code and not with the configuration.

slava 03-30-2010 12:03 AM

Try to change PHP mode in the WWW domain properties to PHP as CGI


All times are GMT +2. The time now is 04:42 PM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.