ISPsystem.com Forums

ISPsystem.com Forums (http://forum.ispsystem.com//index.php)
-   Troubleshooting (http://forum.ispsystem.com//forumdisplay.php?f=11)
-   -   quota inactive (http://forum.ispsystem.com//showthread.php?t=1481)

sascha 07-15-2011 10:39 AM

quota inactive
 
quota is installed, but not active. when i try to enable it in applications:


'func=feature.enable&elid=quota'
Jul 15 09:34:31 [ 3968] INFO Request [ip][root] 'func=feature&clickstat=yes'
Jul 15 09:34:35 [ 3968] INFO Request [pkgctl][root] 'out=xml&func=pathlist&elid=DefaultHomeDir'
Jul 15 09:34:35 [ 3968] INFO Request [pkgctl][root] 'out=text&func=exit'
Jul 15 09:34:35 [ 3968] NOTE Waiting for threads 1
Jul 15 09:34:35 [ 3968] NOTE Last I have to do ...
Jul 15 09:34:37 [ 0] INFO Lookup log level for '/usr/local/ispmgr/var/ispmgr.log' in 'etc/ispmgr.debug'
Jul 15 09:34:37 [ 4142] NOTE ISPmanager-Pro 4.3.53.1 Started. OS Linux-cc6 (x86_64)
Jul 15 09:34:37 [ 4142] NOTE hostname 'hostname'
Jul 15 09:34:37 [ 4142] EXTINFO Load config 'etc/ispmgr.conf'
Jul 15 09:34:37 [ 4142] EXTINFO Load config '/etc/passwd'
Jul 15 09:34:37 [ 4142] EXTINFO Load config '/etc/shadow'
Jul 15 09:34:37 [ 4142] EXTINFO Load config 'etc/ispmgr.ipaccess'
Jul 15 09:34:37 [ 4142] EXTINFO Load config '/etc/mail/local-host-names'
Jul 15 09:34:37 [ 4142] EXTINFO Load config '/etc/mail/access'
Jul 15 09:34:37 [ 4142] EXTINFO Load config '/etc/aliases'
Jul 15 09:34:37 [ 4142] EXTINFO Load config '/etc/mail/virtusertable'
Jul 15 09:34:37 [ 4142] EXTINFO Load config '/etc/mail/generic'
Jul 15 09:34:37 [ 4142] EXTINFO Load config '/etc/postfix/main.cf'
Jul 15 09:34:37 [ 4142] EXTINFO Load config '/etc/dovecot/dovecot.passwd'
Jul 15 09:34:37 [ 4142] EXTINFO Load config '/etc/dovecot/dovecot.passwd'
Jul 15 09:34:37 [ 4142] EXTINFO Load config '/etc/spamassassin/local.cf'
Jul 15 09:34:37 [ 4142] EXTINFO Load config '/etc/apache2/apache2.conf'
Jul 15 09:34:37 [ 4142] INFO Detected apache version '2'
Jul 15 09:34:37 [ 4142] INFO Use ApacheMPM
Jul 15 09:34:37 [ 4142] INFO Apache config test is off
Jul 15 09:34:37 [ 4142] EXTINFO Execute (/usr/sbin/apache2 -M) return=0 exited
Jul 15 09:34:37 [ 4142] EXTINFO Load config 'etc/rotate.conf'
Jul 15 09:34:37 [ 4142] INFO Domain MasterIP 'ip'
Jul 15 09:34:37 [ 4142] EXTINFO Load config '/etc/bind/named.conf'
Jul 15 09:34:37 [ 4142] EXTINFO Load config 'var/userconf/ispmgr.root'
Jul 15 09:34:37 [ 4142] INFO Detected MySQL datadir = '/var/lib/mysql/'
Jul 15 09:34:37 [ 4142] INFO Detected MySQL version: 5.0.51a
Jul 15 09:34:37 [ 4142] INFO User resources limits can be enabled for MySQL database.
Jul 15 09:34:37 [ 4142] INFO User connection number limits can be enabled for MySQL database.
Jul 15 09:34:37 [ 4142] INFO Detect enabled firewall
Jul 15 09:34:37 [ 4142] EXTINFO Load config '/var/lib/iptables/rules'
Jul 15 09:34:37 [ 4142] INFO Detect enabled firewall
Jul 15 09:34:37 [ 4142] EXTINFO Load config '/var/lib/iptables/rules'
Jul 15 09:34:37 [ 4142] EXTINFO Load config '/usr/local/ispmgr/etc/webscripts.conf'
Jul 15 09:34:37 [ 4142] EXTINFO Load config '/usr/local/ispmgr/etc/webscripts.conf.local'
Jul 15 09:34:37 [ 4142] EXTINFO Converting ip assigment
Jul 15 09:34:37 [ 4142] EXTINFO Converting ip done
Jul 15 09:34:37 [ 4142] EXTINFO Execute (crontab -l) return=0 exited
Jul 15 09:34:37 [ 4142] EXTINFO Load config '/var/spool/cron/crontabs/root'
Jul 15 09:34:37 [ 4142] EXTINFO Execute (crontab -l) return=0 exited
Jul 15 09:34:37 [ 4142] NOTE Begin periodic tasks
Jul 15 09:34:37 [ 4142] NOTE Waiting requests
Jul 15 09:34:40 [ 4142] INFO Request [pkgctl][root] 'out=xml&func=longtask.finish&elid=var%2Frun%2Fisp mgr%2Fpkgctl%2Equota&status=ok'

and it is already inactive
OS:debian5

vian 07-15-2011 11:41 AM

please provide us with part of pkgctl.log

sascha 07-15-2011 12:12 PM

Jul 15 11:10:57 [ 0] INFO Lookup log level for '/usr/local/ispmgr/var/pkgctl.log' in 'etc/pkgctl.debug'
Jul 15 11:10:57 [ 7451] ../../src/mgr/install/pkgctl.cpp:612 TRACE pkgctl started
Jul 15 11:10:57 [ 7451] ../../src/mgr/install/pkgctl.cpp:613 DEBUG LogLevel 9
Jul 15 11:10:57 [ 7451] ../../src/mgr/install/pkgctl.cpp:662 TRACE Init pkgmgr
Jul 15 11:10:57 [ 7451] INFO Using package manager 'Apt'
Jul 15 11:10:57 [ 7451] ../../src/mgr/install/pkgctl.cpp:664 TRACE Init way
Jul 15 11:10:57 [ 7451] ../../src/mgr/install/pkgctl.cpp:666 TRACE Init client
Jul 15 11:10:57 [ 7451] ../../src/mgr/install/pkgctl.cpp:672 TRACE Done
Jul 15 11:10:57 [ 7451] ../../src/mgr/install/pkgctl.cpp:510 TRACE LoadModule lib/pkgisp-quota.so
Jul 15 11:10:57 [ 7451] EXTINFO Execute (/bin/egrep -h '^Package: |^Version: ' /var/lib/apt/lists/*_Packages) return=0 exited
Jul 15 11:11:01 [ 7451] ../../src/mgr/install/pkgmgr.cpp:56 TRACE List 'quota' found 1
Jul 15 11:11:01 [ 7451] EXTINFO Execute (/usr/bin/dpkg-query --showformat='${Status} ${Package} ${Version}
' -W '*'|/bin/egrep '^(install|hold) ok installed '|/usr/bin/cut -d' ' -f4,5) return=0 exited
Jul 15 11:11:01 [ 7451] ../../src/mgr/install/pkgmgr.cpp:78 TRACE Has 'quota-3.16-7'
Jul 15 11:11:01 [ 7451] ../../src/ispmgr/feature/pkgquota.cpp:67 DEBUG dev=/dev/md0 mpoint=/ options='defaults,grpquota,usrquota'
Jul 15 11:11:01 [ 7451] EXTINFO Execute (mount -o remount /) return=0 exited
Jul 15 11:11:01 [ 7451] EXTINFO Execute (quotacheck -ugcm /) return=127 exited
Jul 15 11:11:01 [ 7451] EXTINFO Execute (quotaon -uga) return=127 exited
Jul 15 11:11:01 [ 7451] ../../src/ispmgr/feature/pkgquota.cpp:116 DEBUG Quota partition: /
Jul 15 11:11:01 [ 7451] ../../src/mgr/install/pkgmgr.cpp:56 TRACE List 'quota' found 1
Jul 15 11:11:01 [ 7451] ../../src/mgr/install/pkgmgr.cpp:78 TRACE Has 'quota-3.16-7'

sascha 07-15-2011 12:28 PM

maybe ive found the problem?

fstab says

# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
/dev/md0 / xfs defaults,grpquota,usrquota 0 1
/dev/sda2 none swap sw 0 0
/dev/sdb2 none swap sw 0 0
/dev/scd0 /media/cdrom0 udf,iso9660 user,noauto 0 0

the FS is XFS , is that a problem?
but quota is supportet in XFS :)
any solutions?
thx

slava 07-15-2011 02:05 PM

Quote:

Jul 15 11:11:01 [ 7451] EXTINFO Execute (quotacheck -ugcm /) return=127 exited
stantart quota utilities can't be run (quotacheck -ugcm /) and quota can't work with this system.
You can try run this in the shell and see output error.

sascha 07-15-2011 03:35 PM

for XFS you have to use xfs_quota

http://support.coraid.com/support/cl...O/ar01s08.html

i think it is not supported by ISPmanager?

is it possible to list only qustomers quota (used space) in ISPmanager?

slava 07-17-2011 10:37 PM

This is not supported

SilviuB 07-21-2011 08:38 AM

I have the same problem. Using Debian right ?

slava 07-21-2011 03:20 PM

xfs quota is not supported, use ext4 file system

SilviuB 07-25-2011 10:39 PM

So how can we fix the inactive quota ?


All times are GMT +2. The time now is 09:29 AM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2022, vBulletin Solutions, Inc.