ISPsystem.com Forums

ISPsystem.com Forums (http://forum.ispsystem.com//index.php)
-   Troubleshooting (http://forum.ispsystem.com//forumdisplay.php?f=11)
-   -   Disabled Domains (http://forum.ispsystem.com//showthread.php?t=2162)

syntaxsniffer 11-12-2013 11:12 PM

Disabled Domains
 
Hi everyone!
When I disabled a domain in ISPmanager-Pro 4.4.10.20, I expect their current webpage to be replaced with a disabled message that is in "/usr/local/ispmgr/www/disabled/index.html" - I did not create this file but I want it displayed when I disable a domain or it is automatically disabled.

Right now when I disable a domain, ISPManager updates the httpd.conf to include:

Code:

<Directory /var/www/##user##/data/www/##domain name##>
        Options +ExecCGI -Includes
        AllowOverride none
        Deny from all
        ErrorDocument 403 /disabled/index.html
</Directory>

So it looks like it is trying to do this but it's not working... when you visit the domain after it is disabled you get the nice default server page (in my case, Apache 2 Test Page powered by CentOS).

Any thoughts? Is this a genuine bug? I have searched google and these forums but I see no one talking about it.

usaafko 11-13-2013 04:26 AM

Hello, have you restarted Apache manually after disabling a domain in ISPmanager?

syntaxsniffer 11-13-2013 04:32 PM

Yes and the server has been restarted multiple times since the domains were marked as disabled (about a year now).

fly 11-16-2013 02:33 PM

Probably directive Directory is redefine in configure file. Check carefully configure file.

syntaxsniffer 11-18-2013 09:17 PM

Wow, this was a bit crazy...

In order for this disabled page to work, you have to either delete the welcome.conf or comment out all the lines.

This file is located at \etc\httpd\conf.d\welcome.conf

Hopefully someone else that needs this will be able to find it now. Apparently ISPMGR needs to either delete this file upon installation or have a footnote in the installer to disable this file so the disabled pages will work at least on CENTOS... I have no idea about other flavors of Linux and how they handle this file.

Once you edit or delete that welcome.conf file, you can then edit the ispmgr disabled page located in: /usr/local/ispmgr/www/disabled/index.html

Hope this helps someone else. Sad that it does this on a fresh install by default.


All times are GMT +2. The time now is 01:00 AM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2022, vBulletin Solutions, Inc.