ISPsystem.com Forums

ISPsystem.com Forums (http://forum.ispsystem.com//index.php)
-   Troubleshooting (http://forum.ispsystem.com//forumdisplay.php?f=11)
-   -   Postgrey with Exim4 (http://forum.ispsystem.com//showthread.php?t=896)

Mono 01-16-2010 08:09 PM

Postgrey with Exim4
 
Hi!

We installed the Ispmanager with recommended options on Debian 5.0.3 Lenny 64 bit edition.
We go to the admin panel->Server configuration->Features and install postgrey. The postgrey installed succesfully, the bulb color is yellow and running perfectly:

# ps axf | grep postgrey
15794 pts/1 S+ 0:00 \_ grep postgrey
9074 ? Ss 0:00 /usr/sbin/postgrey --pidfile=/var/run/postgrey.pid --daemonize --inet=127.0.0.1:60000 --delay=300 --max-age=45 --greylist-text=Service unavailable. Wait a few minutes and try again.


We modified the /etc/default/postgrey file, this is the current content:

# postgrey startup options, created for Debian
# (c)2004 Adrian von Bidder <avbidder@fortytwo.ch>
# Distribute and/or modify at will.

# you may want to set
# --delay=N how long to greylist, seconds (default: 300)
# --max-age=N delete old entries after N days (default: 35)
# see also the postgrey(8) manpage

#POSTGREY_OPTS="--inet=127.0.0.1:60000"
POSTGREY_OPTS="--inet=127.0.0.1:60000 --delay=300 --max-age=45"

# the --greylist-text commandline argument can not be easily passed through
# POSTGREY_OPTS when it contains spaces. So, insert your text here:
#POSTGREY_TEXT="Your customized rejection message here"
POSTGREY_TEXT="Service unavailable. Wait a few minutes and try again."



We put in the /usr/local/ispmgr/etc/ispmgr.conf the following line:
Option ForcePostgrey

After this steps, we restarted ispmanager with "killall ispmgr" shell command.

But the postgrey don't working. When coming a new email first, the recipient become it in a moment.
We could't find any postgrey message the following log files:
/var/log/messages
/var/log/exim4/mainlog
/var/log/mail.log

Why don't work postgrey? What is the problem?

Thanks!

slava 01-17-2010 03:15 AM

Can you check exim configuration for POSTGREY_SOCKET option?

Mono 01-19-2010 07:18 PM

Dear Slava!

It was a trivial problem.
When we installed the postgrey "feature" in the /etc/default/postgrey configuration file the postgrey listeting on the 60000 TCP port.
And the Exim4 config file (/etc/exim4/exim4.conf.template) wanted communicate with unix socket.
We changed in the postgrey config file from inet= to unix= and working fine.

Thanks!


All times are GMT +2. The time now is 06:36 PM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.