ISPsystem.com Forums

ISPsystem.com Forums (http://forum.ispsystem.com//index.php)
-   Troubleshooting (http://forum.ispsystem.com//forumdisplay.php?f=11)
-   -   FAST CGI issue (http://forum.ispsystem.com//showthread.php?t=894)

jeffm 01-15-2010 03:59 PM

FAST CGI issue
 
Having timeout issues with fasqtcgi and apache. Getting timeout errors as follows:

[warn] (110)Connection timed out: mod_fcgid: ap_pass_brigade failed in handle_request function

[warn] mod_fcgid: read data timeout in 40 seconds

Even though my fastcgi config file has been updated it doesn't seem to make a difference. This could be related to APC.

<IfModule mod_fcgid.c>
AddHandler fcgid-script .fcgi
IdleTimeout 300
**MaxProcessCount 200
**DefaultMinClassProcessCount 1
**DefaultMaxClassProcessCount 25
**IPCConnectTimeout 20
**IPCCommTimeout 120
**IdleScanInterval 120
</IfModule>


I found this posting below that may be related, although I don't know how this would affect my virtual host settings inside ISPManager Pro


The mod_fcgid parameters are wiped out per VirtualHost, so your global settings are ignored.

See http://jay.vox.com/library/post/mod_fcgi...tings.html

slava 01-16-2010 06:41 PM

See http://httpd.apache.org/mod_fcgid/mod/mod_fcgid.html

IPCCommTimeout is old and depricated, you need use FcgidIOTimeout more than 40 seconds, but if you have old version mod_fcgid increase IPCCommTimeout

jeffm 01-18-2010 03:32 AM

php setting
 
Thanks Slava, found another issue. I been trying to change my max_execution_time values and php memory setting in the php.ini files. I have changed them in every php.ini file I could find even the ones referenced in my phpinfo file info listed below. Any ideas?

CGI/FastCGI
Virtual Directory Support disabled
Configuration File (php.ini) Path /etc/php5/cgi
Loaded Configuration File /var/www/tammany/data/php-bin/php.ini
Scan this dir for additional .ini files /etc/php5/cgi/conf.d
additional .ini files parsed /etc/php5/cgi/conf.d/apc.ini, /etc/php5/cgi/conf.d/curl.ini, /etc/php5/cgi/conf.d/gd.ini, /etc/php5/cgi/conf.d/mcrypt.ini, /etc/php5/cgi/conf.d/mysql.ini, /etc/php5/cgi/conf.d/mysqli.ini, /etc/php5/cgi/conf.d/pdo.ini, /etc/php5/cgi/conf.d/pdo_mysql.ini

slava 01-18-2010 01:30 PM

Try edit /var/www/tammany/data/php-bin/php.ini and restart apache, other files is no need for change.

jeffm 01-18-2010 07:23 PM

updated settings
 
The only thing in that file is this:

sendmail_path = "/usr/sbin/sendmail -t -i -f my@email.com"
session.save_path = "/var/www/tammany/data/bin-tmp"
max_execution_time*= 1800
memory_limit = 64M


When my make these changes to the execution time and memory limit in this file the changes are not seen in the phpinfo.

jeffm 01-20-2010 05:31 PM

any other ideas?
 
Any other suggestions Slava? I As I said when I update the file the changes are not reflected in phpinfo.

jeffm 02-02-2010 10:25 PM

fastcgi_params not referenced
 
I was taking a look at my ngnix config file generated by ISP manager. The file does not reference the fastcgi_params config file which I believe is used for fastcgi php. I don't see any php specific parameters in my nginx config file which I am listing below. Doesn't this need to be updated to reference php directly

user www-data;
worker_processes 5;

error_log /var/log/nginx/error.log;
pid /var/run/nginx.pid;

events {
worker_connections 1024;
}

http {
include /etc/nginx/mime.types;
default_type application/octet-stream;

access_log /var/log/nginx/access.log;

sendfile on;
#tcp_nopush on;

#keepalive_timeout 0;
keepalive_timeout 120;
tcp_nodelay on;



gzip on;

include /etc/nginx/sites-enabled/*;

client_max_body_size 16m;
server {
listen xx.xx.45.171:80;
server_name mysite.com www.mysite.com myweb.othersite.net;
rewrite ^(/manager/.*)$ https://$host$1 permanent;
location ~* ^/(webstat/|awstats|webmail/|myadmin/|manimg/) {
proxy_pass http://xx.xx.45.171:8080;
proxy_redirect http://mysite.com:8080/ /;
proxy_set_header Host $host;
proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
proxy_set_header X-Real-IP $remote_addr;

}
location / {
proxy_pass http://xx.xx.45.171:8080;
proxy_redirect http://mysite.com:8080/ /;
proxy_set_header Host $host;
proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
proxy_set_header X-Real-IP $remote_addr;
}
location ~* ^.+\.(jpg|jpeg|gif|png|svg|js|css|mp3|ogg|mpe?g|av i|zip|gz|bz2?|rar)$ {
root /var/www/mysite/data/www/mysite.com;
access_log /var/www/httpd-logs/mysite.com.access.log;
error_page 404 = @fallback;
}
location @fallback {
proxy_pass http://xx.xx.45.171:8080;
proxy_set_header Host $host;
proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
proxy_set_header X-Real-IP $remote_addr;
}
}

netlog 02-22-2010 06:38 PM

All was fine until I installed phpmyadmin. I selected my apache2 server for that install but later discovered I should have selected lighttpd. Even after removing phpmyadmin, any further installations didn't provide that option anymore.

misimano 02-28-2010 09:49 AM

Modify it the /var/www/tammany/data/php-bin/php onto the successor:
 
Quote:

Originally Posted by jeffm (Post 3884)
The only thing in that file is this:

sendmail_path = "/usr/sbin/sendmail -t -i -f my@email.com"
session.save_path = "/var/www/tammany/data/bin-tmp"
max_execution_time*= 1800
memory_limit = 64M


When my make these changes to the execution time and memory limit in this file the changes are not seen in the phpinfo.

Modify it the /var/www/tammany/data/php-bin/php onto the successor:

#!/bin/sh
PHPRC="."
export PHPRC
exec /usr/bin/php-cgi

and restart apache


All times are GMT +2. The time now is 04:25 PM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.