ISPsystem.com Forums

ISPsystem.com Forums (http://forum.ispsystem.com//index.php)
-   General technical discussion (http://forum.ispsystem.com//forumdisplay.php?f=8)
-   -   Problem with exim (sender IP) (http://forum.ispsystem.com//showthread.php?t=2153)

zst_pro 10-15-2013 07:12 PM

Problem with exim (sender IP)
 
Hi all,

exim configuration file did:

interface = ${extract{1}{;}{${lookup{$sender_address_domain}ls earch{/etc/exim4/domainips}}}}

and changed to test for

interface = <;${extract{1}{:}{${lookup{$sender_address_domain} lsearch{/etc/exim4/domainips}}}}

However, all messages continue to be sent to the main server address.
Where to find the problem?

fly 10-16-2013 06:40 AM

Hello,

Show please a file /etc/exim4/domainips

zst_pro 10-16-2013 10:07 AM

Hi,
part of the file you asked for
o***t:XXX.XXX.XX5.162;
e***l:XXX.XXX.XX5.162;
pr***l:XXX.XXX.XX5.188;
i***l:XXX.XXX.XX5.162;
zc***l:XXX.XXX.XX5.187;
a***l:XXX.XXX.XX5.186;
w***l:XXX.XXX.XX5.162;
ksi***l:XXX.XXX.XX5.222;
ksia***l:XXX.XXX.XX5.222;
pf***u:XXX.XXX.XX5.165;
z***l:XXX.XXX.XX5.166;
e***l:XXX.XXX.XX5.169;
ed***pl:XXX.XXX.XX5.169;

fly 10-17-2013 09:28 AM

Try to change interface for
interface = <;${lookup{$sender_address_domain}lsearch{/etc/exim4/domainips}}

It works on my server.

Also show result of command
date | sendmail -v -f test@example.com test2@example.com

zst_pro 10-17-2013 02:03 PM

When I send a message with your configuration (and with others) I get the result:

Quote:

# date | sendmail -v -f biuro@zceXXXl vXXXs@gmail.com
LOG: MAIN
<= biuro@zceXXXl U=root P=local S=319
# delivering 1VWkrU-0005nN-Dv
Connecting to gmail-smtp-in.l.google.com [173.194.66.26]:25 from XX.XXX.XX5.187 ... connected
SMTP<< 220 mx.google.com ESMTP eb10si2379039wib.55 - gsmtp
SMTP>> EHLO shrd1.XXXl
SMTP<< 250-mx.google.com at your service, [XX.XXX.XX5.162]
250-SIZE 35882577
250-8BITMIME
250-STARTTLS
250-ENHANCEDSTATUSCODES
250-PIPELINING
250 CHUNKING
SMTP>> STARTTLS
SMTP<< 220 2.0.0 Ready to start TLS
SMTP>> EHLO shrd1.XXXl
SMTP<< 250-mx.google.com at your service, [XX.XXX.XX5.162]
250-SIZE 35882577
250-8BITMIME
250-ENHANCEDSTATUSCODES
250-PIPELINING
250 CHUNKING
SMTP>> MAIL FROM:<biuro@zXXXl> SIZE=1351
SMTP>> RCPT TO:<vXXX@gmail.com>
SMTP>> DATA
SMTP<< 250 2.1.0 OK eb10si2379039wib.55 - gsmtp
SMTP<< 250 2.1.5 OK eb10si2379039wib.55 - gsmtp
SMTP<< 354 Go ahead eb10si2379039wib.55 - gsmtp
SMTP>> writing message and terminating "."
SMTP<< 250 2.0.0 OK 1382006140 eb10si2379039wib.55 - gsmtp
SMTP>> QUIT
LOG: MAIN
=> vXXX@gmail.com R=dnslookup T=remote_smtp H=gmail-smtp-in.l.google.com [173.194.66.26] X=TLS1.0:RSA_ARCFOUR_SHA1:16 DN="C=US,ST=California,L=Mountain View,O=Google Inc,CN=mx.google.com" C="250 2.0.0 OK 1382006140 eb10si2379039wib.55 - gsmtp"
LOG: MAIN
Completed

but when I check the source of e-mail

Quote:

Received: from shXXXl (162.xxx.xxx.pl. [XX.XXX.XX5.162])

fly 10-18-2013 06:32 AM

As I understand - exim send email from right address - XX.XXX.XX5.187. Then google connected to XX.XXX.XX5.162 for checking a mailbox existing. So, address XX.XXX.XX5.162 is uses for mail delivery.
I think the reason is a mx records of your mail domain. It should point to XX.XXX.XX5.187, but is seems to point to XX.XXX.XX5.162

zst_pro 11-12-2013 11:02 AM

Hm, no MX record is:

zce....pl. 3600 IN MX 10 mail.zce....pl.
zce....pl. 3600 IN MX 20 mail.zce....pl.

and "A"

mail.zce....pl has address 91.....187

when sending a message server presents itself as 91...162 (a first address on the server)


All times are GMT +2. The time now is 12:50 PM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.