ISPsystem.com Forums

ISPsystem.com Forums (http://forum.ispsystem.com//index.php)
-   Troubleshooting (http://forum.ispsystem.com//forumdisplay.php?f=11)
-   -   No "Email Domains" menu (http://forum.ispsystem.com//showthread.php?t=2599)

AD7six 09-11-2016 07:43 PM

No "Email Domains" menu
 
I have a server running ispmanager 4.4.10.29 which has been largely unmodified for several years.

The specific thing I want to see/check is the email configuration - but the menu option simply isn't there. I found http://forum.ispsystem.com/showthread.php?p=6363 which sounds similar, and indeed the admin interface _says_ that various applications are not enabled:

http://dump.ad7six.com/isp-applications.png

except e.g. exim and dovecot are installed and running:
```
root@machine:~# /etc/init.d/exim4 status
[ ok ] checking separate queue runner daemon...done (not running).
[ ok ] checking combined SMTP listener and queue runner daemon...done (running).
root@machine:~# /etc/init.d/dovecot status
[ ok ] dovecot is running.
root@machine:~#
```

Attempting to enable exim via the applications menu doesn't do anything - the gear symbol appears, the page reloads, but the bulb symbol is still grey.

This doesn't look to be the only problem, there are (admin) user-facing issues such as error messages that pre-existing users don't exist:

http://dump.ad7six.com/isp-user.png

Almost certainly relevant: The server ran out of space at some point in the past month, after deleting unused files and logs the server was rebooted - seemingly everything works, only the ispmanager interface doesn't reflect the actual state of the server.

What can cause this and what do I do to address it?

AD7six 11-15-2016 10:33 AM

Bump
 
Please advise whether this is a problem with ispmanager, and whether it's recoverable or I should simply remove the software and seek a different solution.

fly 11-16-2016 04:39 AM

Hello

To understand why exim can't be activated you need to see /usr/local/ispmgr/var/pkgctl.log

As for user doesn't exist, user could not exists in the /ect/passwd file . Check it or also log of ISPmanager could be helpful here.

AD7six 11-18-2016 03:53 PM

Thanks that's a great help.

The log finishes with:

Can't activate exim4-4.80-7, there is no LDA installed

After enabling maildrop via the applications menu I was able to "enable" exim via the applications menu.

My problem is still the same though, to be slightly more specific: My objective is t allow access to the mailboxes+Email domains admin screens to a specific not-root user as they previously could.

As root I can now access mailboxes, so I'm a step closer but they cannot. This is all the other user can see:

Code:

        Management Tools
        File manager
        Scheduler (cron)

        Maintenance
        Backup archives
        Backup plan management
        User import
        Back up files

        Server Statistics
        Usage statistics
        Disk usage
        Bandwidth
        Error log
        Http-server load

        Other Settings
        Favourites
        General settings

        Help
        Help
        Video tutorials

I have checked the docs to make sure I'm not missing something super obvious (http://en.ispdoc.com/index.php/Acces...es_(ISPmanager)) but mailboxes is set to "Allowed for all".

I note that creating a new user, the new user can access email admin screens - but the existing user cannot.

How do I correct this?

fly 11-21-2016 10:16 AM

If user can't see Mailboxes and Email domains it could be something wrong configured.

Try to execute /usr/local/ispmgr/sbin/mgrctl -m ispmgr email su=<username> to see is there some error or not ?

AD7six 11-23-2016 03:39 PM

That command produces a long list of email addresses that the user manages:

Code:

/usr/local/ispmgr/sbin/mgrctl -m ispmgr email su=name
name=a@example.com forward size=0/0
name=b@another.example.com forward size=0/0
...

There's an increasing list of things that do not work in the admin:

* Cannot edit any email - Error: "The '' record not found"
* Cannot add an email to any existing domain - Error: "The example.com domain does not have an owner "
* No email domains have an owner (there are about 50 domains, all should have the same owner)
* Cannot define an owner for any email domain because the owner form input isn't present for editing an existing domain

What action should I take here, am I in a user-recoverable scenario? It would be very annoying to need to reinstall from scratch especially since things actually work - yet it feels atm like it's going to be one problem after another. It would be equally annoying to upgrade and find that things are in the same broken state.

Thanks for your continued input

fly 11-24-2016 12:46 PM

It seems some files are wrong. It could be exim.passwd or dovecot.passwd
But it is very difficult to understand exactly wrong without server assess seeing a logs, files etc.

The issue could be solved by support team if you write to support via client area but we do not support ISPmanager 4 anymore. So, I recommend you to switch to ISPmanager 5.


All times are GMT +2. The time now is 12:05 AM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2022, vBulletin Solutions, Inc.