Go Back   ISPsystem.com Forums > ISPmanager > Troubleshooting

Notices

Reply
 
Thread Tools
Old 01-15-2010, 03:59 PM   #1
Junior Member
 
Join Date: Jan 2010
Posts: 7
jeffm is on a distinguished road
Default FAST CGI issue

Having timeout issues with fasqtcgi and apache. Getting timeout errors as follows:

[warn] (110)Connection timed out: mod_fcgid: ap_pass_brigade failed in handle_request function

[warn] mod_fcgid: read data timeout in 40 seconds

Even though my fastcgi config file has been updated it doesn't seem to make a difference. This could be related to APC.

<IfModule mod_fcgid.c>
AddHandler fcgid-script .fcgi
IdleTimeout 300
**MaxProcessCount 200
**DefaultMinClassProcessCount 1
**DefaultMaxClassProcessCount 25
**IPCConnectTimeout 20
**IPCCommTimeout 120
**IdleScanInterval 120
</IfModule>


I found this posting below that may be related, although I don't know how this would affect my virtual host settings inside ISPManager Pro


The mod_fcgid parameters are wiped out per VirtualHost, so your global settings are ignored.

See http://jay.vox.com/library/post/mod_fcgi...tings.html
jeffm is offline   Reply With Quote
Old 01-16-2010, 06:41 PM   #2
ISPsystem team
 
slava's Avatar
 
Join Date: May 2008
Location: ISPsystem
Posts: 588
slava is on a distinguished road
Default

See http://httpd.apache.org/mod_fcgid/mod/mod_fcgid.html

IPCCommTimeout is old and depricated, you need use FcgidIOTimeout more than 40 seconds, but if you have old version mod_fcgid increase IPCCommTimeout
slava is offline   Reply With Quote
Old 01-18-2010, 03:32 AM   #3
Junior Member
 
Join Date: Jan 2010
Posts: 7
jeffm is on a distinguished road
Default php setting

Thanks Slava, found another issue. I been trying to change my max_execution_time values and php memory setting in the php.ini files. I have changed them in every php.ini file I could find even the ones referenced in my phpinfo file info listed below. Any ideas?

CGI/FastCGI
Virtual Directory Support disabled
Configuration File (php.ini) Path /etc/php5/cgi
Loaded Configuration File /var/www/tammany/data/php-bin/php.ini
Scan this dir for additional .ini files /etc/php5/cgi/conf.d
additional .ini files parsed /etc/php5/cgi/conf.d/apc.ini, /etc/php5/cgi/conf.d/curl.ini, /etc/php5/cgi/conf.d/gd.ini, /etc/php5/cgi/conf.d/mcrypt.ini, /etc/php5/cgi/conf.d/mysql.ini, /etc/php5/cgi/conf.d/mysqli.ini, /etc/php5/cgi/conf.d/pdo.ini, /etc/php5/cgi/conf.d/pdo_mysql.ini
jeffm is offline   Reply With Quote
Old 01-18-2010, 01:30 PM   #4
ISPsystem team
 
slava's Avatar
 
Join Date: May 2008
Location: ISPsystem
Posts: 588
slava is on a distinguished road
Default

Try edit /var/www/tammany/data/php-bin/php.ini and restart apache, other files is no need for change.
slava is offline   Reply With Quote
Old 01-18-2010, 07:23 PM   #5
Junior Member
 
Join Date: Jan 2010
Posts: 7
jeffm is on a distinguished road
Default updated settings

The only thing in that file is this:

sendmail_path = "/usr/sbin/sendmail -t -i -f my@email.com"
session.save_path = "/var/www/tammany/data/bin-tmp"
max_execution_time*= 1800
memory_limit = 64M


When my make these changes to the execution time and memory limit in this file the changes are not seen in the phpinfo.
jeffm is offline   Reply With Quote
Old 01-20-2010, 05:31 PM   #6
Junior Member
 
Join Date: Jan 2010
Posts: 7
jeffm is on a distinguished road
Default any other ideas?

Any other suggestions Slava? I As I said when I update the file the changes are not reflected in phpinfo.
jeffm is offline   Reply With Quote
Old 02-02-2010, 10:25 PM   #7
Junior Member
 
Join Date: Jan 2010
Posts: 7
jeffm is on a distinguished road
Default fastcgi_params not referenced

I was taking a look at my ngnix config file generated by ISP manager. The file does not reference the fastcgi_params config file which I believe is used for fastcgi php. I don't see any php specific parameters in my nginx config file which I am listing below. Doesn't this need to be updated to reference php directly

user www-data;
worker_processes 5;

error_log /var/log/nginx/error.log;
pid /var/run/nginx.pid;

events {
worker_connections 1024;
}

http {
include /etc/nginx/mime.types;
default_type application/octet-stream;

access_log /var/log/nginx/access.log;

sendfile on;
#tcp_nopush on;

#keepalive_timeout 0;
keepalive_timeout 120;
tcp_nodelay on;



gzip on;

include /etc/nginx/sites-enabled/*;

client_max_body_size 16m;
server {
listen xx.xx.45.171:80;
server_name mysite.com www.mysite.com myweb.othersite.net;
rewrite ^(/manager/.*)$ https://$host$1 permanent;
location ~* ^/(webstat/|awstats|webmail/|myadmin/|manimg/) {
proxy_pass http://xx.xx.45.171:8080;
proxy_redirect http://mysite.com:8080/ /;
proxy_set_header Host $host;
proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
proxy_set_header X-Real-IP $remote_addr;

}
location / {
proxy_pass http://xx.xx.45.171:8080;
proxy_redirect http://mysite.com:8080/ /;
proxy_set_header Host $host;
proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
proxy_set_header X-Real-IP $remote_addr;
}
location ~* ^.+\.(jpg|jpeg|gif|png|svg|js|css|mp3|ogg|mpe?g|av i|zip|gz|bz2?|rar)$ {
root /var/www/mysite/data/www/mysite.com;
access_log /var/www/httpd-logs/mysite.com.access.log;
error_page 404 = @fallback;
}
location @fallback {
proxy_pass http://xx.xx.45.171:8080;
proxy_set_header Host $host;
proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
proxy_set_header X-Real-IP $remote_addr;
}
}
jeffm is offline   Reply With Quote
Old 02-22-2010, 06:38 PM   #8
Junior Member
 
Join Date: Feb 2010
Location: Bangladesh
Posts: 1
netlog is on a distinguished road
Default

All was fine until I installed phpmyadmin. I selected my apache2 server for that install but later discovered I should have selected lighttpd. Even after removing phpmyadmin, any further installations didn't provide that option anymore.
__________________
online jobs at home

Last edited by netlog; 03-08-2012 at 01:46 PM.
netlog is offline   Reply With Quote
Old 02-28-2010, 09:49 AM   #9
Junior Member
 
Join Date: Jun 2009
Posts: 1
misimano is on a distinguished road
Default Modify it the /var/www/tammany/data/php-bin/php onto the successor:

Quote:
Originally Posted by jeffm View Post
The only thing in that file is this:

sendmail_path = "/usr/sbin/sendmail -t -i -f my@email.com"
session.save_path = "/var/www/tammany/data/bin-tmp"
max_execution_time*= 1800
memory_limit = 64M


When my make these changes to the execution time and memory limit in this file the changes are not seen in the phpinfo.
Modify it the /var/www/tammany/data/php-bin/php onto the successor:

#!/bin/sh
PHPRC="."
export PHPRC
exec /usr/bin/php-cgi

and restart apache
misimano is offline   Reply With Quote
Reply

Tags
apache, cgi, fastcgi

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 12:48 PM.